S3 IAM Role based Authentication connection failures
Incident Report for Workato
Resolved
A fix was deployed to bring connections back up. We still encourage customers to update their connections to use specified external id as documented in https://docs.workato.com/connectors/s3/connection-setup.html#connect-to-amazon-s3-using-iam-role. We are able to support affected customers with automated recovery of affected jobs and Audit Log Streaming. Please contact your CS representative.
Posted Jul 30, 2021 - 05:17 PDT
Identified
S3 connections using IAM Role based Authentication that do not have the external id specified in the connection settings are failing. Customers should update their IAM Roles to include those specified external ids. Please refer to https://docs.workato.com/connectors/s3/connection-setup.html#connect-to-amazon-s3-using-iam-role for help on how to set it up.
Posted Jul 30, 2021 - 01:12 PDT
This incident affected: Recipe runtime (Recipe job execution).