Workato Go Service Disruption

Incident Report for Workato Americas

Resolved

Workato Go access has been restored and knowledge base creation and retrieval are functioning as expected. If you continue to experience any issues, please contact Workato Support at https://support.workato.com.
Posted May 07, 2026 - 21:23 PDT

Identified

We are continuing to investigate the issue affecting Workato Go, which is related to an ongoing incident with AWS. The following capabilities are currently impacted:

- Access to Workato Go is unavailable
- Knowledge base creation is impacted as ingestion services are currently down
- Knowledge base retrieval is unavailable; data from configured knowledge bases cannot be retrieved until this issue is resolved

We are actively monitoring the situation and will provide further updates.

Reference: AWS Service Health Dashboard – https://health.aws.amazon.com/health/status
Posted May 07, 2026 - 19:55 PDT

Update

We are continuing to investigate this issue.
Posted May 07, 2026 - 18:20 PDT

Investigating

We are currently investigating an issue affecting access to Workato Go. Some users may experience difficulties loading the application. Our team is actively working to restore full access and will provide updates as the situation develops.
Posted May 07, 2026 - 18:17 PDT
This incident affected: Workato GO.