Networking / DNS resolution sporadic errors
Incident Report for Workato
Resolved
The upstream issue has been resolved, and we have continued to see no more of these errors.
Posted Apr 02, 2021 - 00:28 PDT
Monitoring
At this point we are no longer seeing these DNS errors. Our cloud provider is reporting recovery with DNS resolution as well.
Posted Apr 02, 2021 - 00:06 PDT
Identified
We are seeing sporadic errors, specifically DNS requests failing to various API endpoints. These cause errors in job execution and trigger polls.

We have traced this to an ongoing networking issue with our hosting provider. In the meantime, we have moved workload out of the most affected data center, further reducing the incidence of these errors down to a very low number.
Posted Apr 01, 2021 - 23:38 PDT
This incident affected: Recipe runtime (Recipe job execution).