Environment switching problem

Incident Report for Workato US

Resolved

The incident has been resolved. Customers with Automation HQ should now be able to use the environment switcher. Customers with connections using AWS IAM roles to authenticate with AWS services such as AWS S3 or AWS Lambda may have experienced jobs failing with the error message "Internal Error". Connections using AWS Secrets Manager may have experienced job failures with the error message "Couldn't find FederatedAccount without an ID". These errors may have been observed in both API Platform and non-API Platform recipes. Customers may also have observed delays in creating jobs with polling triggers, while jobs for recipes with real-time triggers may either be missing or delayed. Customers may also have experienced connections being disconnected after several errors. Customers may now repeat any failed jobs as required. If you continue to experience any issues, please contact Workato Support at support.workato.com.
Posted Feb 27, 2025 - 09:52 PST

Monitoring

Our team has taken steps to remediate the incident and is seeing improvement. We are continuing to monitor for any additional impact.
Posted Feb 27, 2025 - 08:55 PST

Identified

We have identified the underlying cause of the incident and we are working to take remediating steps. We will provide more updates shortly.
Posted Feb 27, 2025 - 07:13 PST

Update

Customers may clear their cookies for app.workato.com to access the Workato platform but will continue to be unable to switch environments. We are continuing to investigate the issue.
Posted Feb 27, 2025 - 06:57 PST

Update

The issue is affecting Automation HQ customers' ability to switch between environments. We are continuing to investigate.
Posted Feb 27, 2025 - 06:04 PST

Investigating

We are currently investigating an incident affecting our platform. We will provide additional information on all affected components as soon as it becomes available.
Posted Feb 27, 2025 - 05:37 PST
This incident affected: Website.