Workspace UI Errors

Incident Report for Workato Americas

Resolved

After further monitoring, this issue is now considered resolved. Customers should no longer experience any errors in the UI. If you continue to experience any issues, please contact Workato Support at https://support.workato.com.
Posted Dec 03, 2025 - 12:16 PST

Monitoring

Our team has taken steps to remediate the issue and is seeing improvement. We are continuing to monitor the platform as it recovers.
Posted Dec 03, 2025 - 12:10 PST

Update

We continue to investigate an issue affecting our platform. Customers may observe errors when interacting with the Workato Platform's UI. Workato's Orchestrate Runtime is unaffected and customers should not experience any errors or delays with job processing. We will continue to share additional information as soon as it becomes available.
Posted Dec 03, 2025 - 12:00 PST

Investigating

We are investigating an issue impacting our platform. We will share additional information on all affected components as soon as it is available.
Posted Dec 03, 2025 - 11:54 PST
This incident affected: Workato Orchestrate (Workspace UI).