Increased 429 errors for Embedded API

Incident Report for Workato US

Resolved

After further monitoring, this issue is now considered resolved and customers should no longer experience 429 errors when interacting with the Embedded Partner Platform APIs. If you continue to experience any issues, please contact Workato Support at support.workato.com.
Posted Jul 10, 2025 - 13:28 PDT

Monitoring

Our team has taken steps to remediate the issue and is seeing improvement. We are continuing to monitor the platform as it recovers.
Posted Jul 10, 2025 - 13:07 PDT

Identified

Customers using Workato's Embedded Partner Platform APIs may be experiencing an increased rate of "429 Too Many Requests" errors. We have identified the issue and are working on a fix. We will share updates as soon as they are available.
Posted Jul 10, 2025 - 11:37 PDT